QL-800

よくあるご質問(Q&A)

よくあるご質問(Q&A)

Excel のデータを利用した宛名ラベルの作り方 (連結フィールドを使ったラベル作成) (Windows向け P-touch Editor 5.1/5.2)

下記の宛名ラベルの作り方の手順に沿って、 Excel ファイルの接続方法や、 連結フィールドの設定方法、 データのマージ方法について、 説明します。
 
Image

 

データベースを準備します
 
  1. 下記のような、 Microsoft Excel で作成された住所録から、 ラベルを作成します。
Image

 

データベースに接続します
 
  1. メニューの 「ファイル」 - 「データベース」 - 「接続...」 をクリックします。
Image

 

  1. 「データベースを開く」 ダイアログが表示されます。 「データベースファイルに接続する」 を選択し、 「参照(M)...」 ボタンをクリックします。
Image

 

  1. 用意した Excel ファイルを選択します。 「先頭行をフィールド名として使用する」 のチェックがオンになっていることを確認してください。 接続するデータベースの編集モードを選択します。 ここでは、 「読み取り専用で接続する」 を選択し、 「次へ(N)」 ボタンをクリックします。
Image

 

  1. お使いになるファイルに複数のシートが含まれている場合は、 「データベーステーブルの選択」 画面が表示されますので、 接続したいシートを選択してください。
  2. データベースが表示されます。
Image

 

フィールドを連結します

まず、 「住所 1」 と 「住所 2」 のフィールドを連結します。 連結することによって、 異なる長さのデータを体裁よく配置することができます。 例えば 「住所 1」 と 「住所 2」 を連結せずにマージすると、 データの長さによって、 次のような問題が起こります。
 
  • 「住所 1」 のサイズを 「神奈川県」 に合わせると、 「東京都」 の後に空白ができてしまいます。
Image

 

  • 次に 「東京都」 に合わせると、 「神奈川県」 の文字サイズが小さくなってしまいます。
Image

 

  • そこで、 連結してマージすると上記の問題が解消され、 体裁が整います。
Image

 

  1. メニューバーに 「データベース(D)」 を表示させるため、 接続されているデータベース上をクリックします。 「データベース(D)」 - 「連結フィールド(J)...」 をクリックします。
Image

 

  1. 「連結フィールドの定義」 ダイアログが表示されます。 「追加」 ボタンをクリックします。
Image

 

  1. 「連結フィールドの追加」 ダイアログが表示されます。 「フィールド一覧」 のリストから、 「住所1」 を選び、 「追加」 ボタンをクリックします。
Image

 

  1. 同様に、 「住所 2」 を選び、「追加」 ボタンをクリックします。 [OK] をクリックします。
Imge

 

  1. 「連結フィールドの定義」 ダイアログが表示されます。「追加」 ボタンをクリックします。
Image

 

  1. 「連結フィールドの追加」 ダイアログが表示されます。 「氏名」 を選び、 「追加」 ボタンをクリックします。 「データ」 のテキストボックス内に表示された 「氏名」 の後に、 スペースと "様" を入力し、 [OK] をクリックします。
Image

 

  1. 「連結フィールドの定義」 ダイアログが表示されます。 「閉じる」 をクリックします。
Image

複数行にわたる連結フィールドにしたい場合は、 [Enter] キー を押し改行します。
「\n」 を入力しても改行になります。

 

データをレイアウトにマージします
 
  1. メニューから 「挿入」 - 「データベースフィールド」 をクリックします。
Image

 

  1. 「フィールドの選択」 ダイアログが表示されます。 「追加形式」 のドロップダウンリストから 「テキスト」 を、 「追加可能なデータベースフィールド」 リストから、 連結されたフィールド [住所1] [住所2] を選び、 [OK] をクリックします。
Image

 

  1. 連結された 「住所1」 と 「住所2」 の二つのフィールドが、 レイアウト画面にマージされます。
Image

 

  1. 同様に、 [氏名] 様 をマージします。
Image

 

  1. それぞれの位置、 高さ、 サイズを調節します。
Image

 

印刷します
 
  1. メニューから 「ファイル」 - 「印刷」 を選びます。
  2. 「印刷」 ダイアログが表示されます。 印刷したい レコード範囲 (*) を選択します。
Image

 

  1. 設定が終了したら、 「印刷」 ボタンをクリックして印刷を開始します。

     

    * レコード範囲については 下記の表を参照してください。
    印刷範囲 印刷対象データ
    すべて すべてのレコードが対象となります。
    現在のレコード 現在表示されているレコードが対象となります。
    マークされたレコード データベースウィンドウで選択されているレコードが対象となります。
    範囲指定 「から」 「まで」 で指定されたレコード範囲が対象となります。

対象製品

PT-24 , PT-2430PC, PT-2730, PT-9500pc, PT-9700PC, PT-9800PCN, PT-D600, PT-P700, PT-P710BT, PT-P750W, PT-P900W, PT-P950NW, QL-1115NWB, QL-550, QL-580N, QL-650TD, QL-700, QL-720NW, QL-800, QL-820NWB, RJ-2030, RJ-2050, RJ-2140, RJ-2150, RJ-3050, RJ-3050Ai, RJ-3150, RJ-3150Ai, RJ-4030, RJ-4030Ai, RJ-4040, RJ-4230B, RJ-4250WB, TD-2130N/ 2130NSA, TD-4000, TD-4100N, TD-4420DN, TD-4510D, TD-4550DNWB, TP-M5000N

アンケートご協力のお願い

よろしければアンケートにご協力ください。 よりよい情報提供ができるよう改善に努めてまいります。

このQ&Aはお客さまの問題解決にお役にたてましたか?

コメント

このコメント欄へのお問い合わせには返答できません。
こちらにはお客さまのご連絡先等,個人情報に関係する内容は記載しないようにお願いいたします。

別のQ&Aを探しますか?